Sidebar Widget Collapser "Released"

What a great idea to be able to have the functionality of offering your site visitors the ability to collapse a portion of the sidebar. Add to that the cookie functionality to “remember” the choices that your visitors make, and conceptually at least, this would be a GREAT plugin.

The reality however is far from GREAT, unfortunately. If you are like most WP owner/operators, you probably don’t get under the hood too much and alter code. If you are a bit more adventurous, and I think I’d put myself into that category, you are willing to get some grease on your hands in order to get things to work on your site the way you’d like them to. However, when you install an add-on (be it widget, plugin or theme) you kind of sort of expect that if it has been released to the public there was some semblance of preparation done to get it ready for the “least common denominator”. This Sidebar widget collapser plugin was definitely not prepped for “the rest of us”.

There is no admin page to enable the admin user to make changes to the hard coded defaults of what the id name that is identifying your sidebar. For instance, the author states very clearly (on his download page, but not in the readme.txt packaged with the plugin; oh, my apologies, there was not any readme.txt with the download package 😥 ) that the plugin expects that your sidebar id will be named “sidebar”. That’s groovy and all, however I don’t want my users to be able to collapse my main left sidebar. Instead, I would want them to have the ability, if they desired, to collapse sections on my rightbar. Now I have to either change the plugin code, or change my custom theme template code. Same goes with the class names for the LI’s in the page.

Worse thing though is that if you don’t look into the code, you will most definitely miss the fact that the plugin is expecting to find the javascript workhorse for this plugin in a folder that theoretically resides in your WP installs Plugin directory, called freepress (after the authors web site.) And that’s cool, except for the fact that when you decompress the package, it seems not to have the files packed up inside a directory called “freepress”, so you are left to assume that the directory they are in, SidebarWidgetCollapser is what you are to upload to your installation. That won’t work, unfortunately.

I will say that the author of this plugin did mention to a commenter at his site that he recognizes the some of these challenges, and will address them “soon”. If that’s the case, why on earth have your download available. I can only imagine that there are going to be a torrent of comments and tech request flooding into his site related to those challenges. Maybe this is the desired affect? Who knows.

We’ll keep our eyes on this plugin however, as we’d truly like the functionality. We’d also like an admin page that gives us the power to name the ID of the sidebar we want the collapsing activity to apply to. It’d be a real bonus to have the ability to have various ID’s named as well, since more and more themes are coming with widgets in more places than just the main left sidebar.

Keeping our fingers crossed!

FreePress Blog » Blog Archive » Sidebar Widget Collapser Released

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s